Installation der aktuellen DisplayManager-Software unter openSUSE 13.1

Setzt man auf openSUSE 13.1 und will man bei der aktuellen Meyton-Software, Version 4.3.5, Stand 14.06.2014, den DisplayManager installieren, so schlägt dies leider fehl, da die Software abhängig von einer anderen ist. Das Setup, wie hier beschrieben, bemängelt, dass das Paket xorg-x11 nicht vorhanden sei und daher die Installation nicht ausüfhren kann.

Man kann das Setup aber dennoch zwingen die Installation auszuführen, indem man auf die Prüfung der Abnhängigkeiten verzichtet. Im Normalfall ist es aber so, dass die zu installierende Software dann nicht funktioniert, da die Abhängigkeit von einer anderen Software nicht ohne Grund existert. In diesem Fall hat es allerdings keine Auswirkungen auf den DisplayManager, der danach wie gewohnt funktioniert – ich denke, es liegt daran, dass das eine oder andere Paket einen anderen Namen bekommen hat, die Funktionalität, die der DisplayManager aber benötigt, dennoch gegeben ist.

Schritt für Schritt Anleitung zur Installation der DisplayManager-Software:

  1. Startmenü über grünes, rundes Icon links unten öffnen
  2. Terminal öffnen – meist unter Favoriten eingetragen
  3. Eingabe des Befehls cd /var/NextRPMs/ [Enter]
  4. Eingabe des Befehls sudo rpm -ivh --nodeps SMIIDC [Tab] [Enter]
  5. Eingabe des Kenntworts mc4hct [Enter] – Hinweis: Kennwort-Eingaben im Terminal wird nicht dargestellt
  6. Computer neu starten

Nun sollte das Paket installiert sein und funktionieren.

6 thoughts on “Installation der aktuellen DisplayManager-Software unter openSUSE 13.1”

  1. Hallo,
    wollte auf unserem Rechner auch suse 13.1 installieren. Hat eigentlich alles geklappt. Nur nach der letzten Anmeldung als root und die Konsole gestartet hat, hatte ich einen Klötzchenbildschirm.
    Im I-net gesucht und da wurde geschrieben, man sollte nomodeset beim booten eingeben – habe nochmal installiert mit nomodeset und die Installation hat auch bis zum Ende funktioniert.
    Aber jetzt kann ich die Meyton-Software nicht zu Ende installieren, weil die Bildschirmauflösung mir den “weiter”-Button nicht mehr anzeigt.
    Wie kann ich das nomodeset beim Booten wieder entfernen oder muß ich da irgendwelche Grafiktreiber installieren?
    Habe mit Linux eigentlich nichts zu tun, nur durch den Rechner mit der Meytonsoftware fürs Schießen.

    Vielleicht könnten Sie mir weiterhelfen?
    LG
    A. K.

    1. Hallo!

      Das mit dem nomodeset an der Stelle finde ich mehr als seltsam, da der Rechner ja scheinbar schon mal gebootet hatte. Eine Anmeldung an der Konsole dürfte eigentlich nicht zu so einem Verhalten führen, zumindest meiner Erfahrung nach. Aber gut, wenn es hilft, dann ist es okay! Daher würde ich das mit dem nomodeset auch belassen.

      Haben Sie schon mal versucht die Auflösung zu erhöhen? Damit erreichen Sie, dass mehr Pixel und somit mehr Inhalt dargestellt wird. Das Setup müsste dann auch wieder komplett sichtbar sein. Dazu gehen Sie wie folgt vor: Melden Sie sich am Rechner an, klicken Sie links unten auf den grünen, runden Button und suchen Sie nach Systemeinstellungen. In dem sich öffnenden Fenster gibt es eine Gruppe namens Hardware und dort den Unterpunkt Anzeige und Monitor. Unter Größe und Ausrichtung können Sie die Auflösung des Monitors einstellen. Dazu ändern Sie die Eigenschaft Größe des jeweiligen Monitors – ist nur einer angeschlossen, so ist dieser automatisch gewählt. Am besten wäre, dass Sie vorher in Erfahrung bringen was die maximale Auflösung des Monitors ist und stellen exakt diese ein. Danach sollten Sie mit dem Setup kein Problem mehr haben.

      mfg Armin

      1. Hallo,
        danke für die Rückantwort.
        Leider gibt es hier nur eine Einstellung zum auswählen.
        640×480 – Auto 73.0 Hz
        ..mehr kann nicht eingestellt werden.

        Hab dann mal Suse 12.3 inst. und da hat die Suseinstallation geklappt. Auch die Data.bin konnte ich installieren.
        Aber die Meytonsoftware taucht nirgends auf – normalerweise startet sie von selbst beim Hochfahren.
        Auf Meytonseite nachgeschaut – man soll im Konsolenprogramm “smcc” eingeben, dann sollte das Programm starten.
        Also bei mir startet nichts!
        Ich mach jetzt schon eine Woche damit rum – langsam nervt´s.
        Auf meinem eigenen Laptop(ist zum probieren mit Suse 12.3) gab es keine Probleme. Hab gedacht dann mach ich es auch mit dem Rechner vom Verein, ist ja eigentlich gleich gemacht.

        Mal schaun wie es weitergeht.

        mfg A. K.

        1. Hm… Das mit der Auflösung ist seltsam. Würde sagen, da passt was mit dem geladenen Treiber nicht, was wiederum mit dem nomodeset zu tun haben kann. Ein Idee wäre es openSUSE (wichtig: unbedingt die 32-bit Version!) neu zu installieren, alles aktuellen Updates aufzuspielen und dann die zweite Lösung, die ich hier vorgeschlagen habe, zu testen.

          Was für einen Rechner haben Sie denn? Welcher Prozessor und welche Grafikkarte sind denn verbaut? Eveneutll kann es notwendigt sein, dass ein neuer Kernel installiert werden muss, je nach Aktualität der Hardware.

          Das Problem mit dem nicht startenden Meyton-Kontrollzentrum hatte ich noch nicht. Müsste hier echt blind spekulieren, woran das liegen kann. Haben Sie das Setup auch unter dem Benutzer root ausgeführt? Denn nur dort haben Sie entsprechende Rechte.

  2. Hallo,
    muss mich entschuldigen, dass ich solange nichts von mir hören lies.
    Wir hatten eine Woche kein Internet(Blitzeinschlag auf Sender) – Internet auf dem Land ist halt noch schwierig und anderes war vorrangig zu erledigen.
    Habe also Suse 13.1 nochmal neu aufgesetzt – dasselbe wie vorher.
    Jetzt mal eine Grafikkarte eingebaut(vorher Onboard) – und was solch ich sagen, es läuft.
    Meytonsoftware inst. – funktioniert auch.

    Nochmal Danke für Ihre Unterstützung
    mfg A. K.

Leave a Reply

Your email address will not be published. Required fields are marked *

Captcha * Time limit is exhausted. Please reload CAPTCHA.